Cisco路由重分布设置

Cisco路由重分布

网络工程师路由重分布设置解析

【实验名称】
网络工程师路由协议间的重分布

【实验目的】
掌握OSPF与RIP路由协议之间的重分布。

【背景描述】
你是一名高级网络工程师,现有一网络扩建工程如下,某公司业务拓展,收购了另外一公司,新收购的公司原来的网络运行OSPF协议,总公司及其下属公司运行RIP协议,为了使总公司和子公司正常更新路由信息,需要进行路由双向重分布,请你实现。R3代表总公司,R1代表新公司,R2代表老子公司。

【实现功能】
通过指定路由器路由更新,控制路由信息的传输。

【实验设备】
R2624路由器(3台)、V35DCE(2根)、V35DTE(2根)

【实验步骤】

第一步:基本配置
Red-Giant#configure t
Red-Giant(config)#hostname R1 !配置主机名
R1(config)# interface serial 0
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#interface loopback 0 !声明一个回环接口,模拟一个网段
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#end

Red-Giant#configure t
Red-Giant(config)#hostname R2
R2(config)# interface fastethernet 0
R2(config-if)#ip address 192.168.123.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#interface loopback 0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#end

Red-Giant#configure t
Red-Giant(config)#hostname R3
R3(config)# interface serial 0
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#no sh

R3(config)# interface fastethernet 0
R3(config-if)#ip address 192.168.123.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#interface loopback 0
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#end

验证测试: R2#ping 192.168.123.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.168.123.1, timeout is 2 seconds:
!!!!!
R3#ping 192.168.13.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.168.13.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
R3#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.168.123.2, timeout is 2 seconds:
!!!!!

第二步:配置路由协议
R3(config)#router rip ! 启动RIP路由协议
R3(config-router)#version 2 !设置RIP版本
R3(config-router)#net 192.168.123.0 !声明RIP路由协议的网段
R3(config-router)#net 192.168.3.0
R3(config-router)#exi
R3(config)#router os 1 ! 启动OSPF路由协议
R3(config-router)# net 192.168.13.0 0.0.0.255 area 0 !声明OSPF路由协议的网段及区域
R3(config-router)#exi

R2(config)#router rip
R2(config-router)#ver 2
R2(config-router)#net 192.168.123.0
R2(config-router)# net 192.168.2.0
R2(config-router)#end

R1(config)#router ospf 1
R1(config-router)#net 192.168.13.0 0.0.0.255 area 0
R1(config-router)#net 192.168.1.0 0.0.0.255 area 1
R1(config-router)#end

验证测试:R1#sh ip ro
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.13.0/24 is directly connected, Serial0
C 192.168.1.0/24 is directly connected, Loopback0
R2#sh ip ro
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.123.0/24 is directly connected, FastEthernet0
C 192.168.2.0/24 is directly connected, Loopback0
R 192.168.3.0/24 [120/1] via 192.168.123.3, 00:00:17, FastEthernet0
R3#sh ip ro
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.123.0/24 is directly connected, FastEthernet0
C 192.168.13.0/24 is directly connected, Serial0
192.168.1.0/32 is subnetted, 1 subnets
O IA 192.168.1.1 [110/49] via 192.168.13.1, 00:00:35, Serial0
R 192.168.2.0/24 [120/1] via 192.168.123.2, 00:00:14, FastEthernet0
C 192.168.3.0/24 is directly connected, Loopback0

第三步:双向重分布路由
R3(config)#router os 1
R3(config-router)#redistribute rip metric-type 1 metric 10 subnets ! 向ospf协议里发布rip信息
R3(config)#router rip
R3(config-router)#redistribute ospf 1 metric 3 !向rip协议里发布ospf信息
R3(config-router)#end

【注意事项】
注意是双向重发布。

【参考配置】
R3# sh run

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*