Cisco路由器RIP V2配置

Cisco路由器ripv2配置

网络工程师Cisco路由器RIP V2配置解析
【实验目的】
掌握在路由器上配置RIP V2。
【背景描述】
假设校园网通过1台三层交换机连到校园网出口路由器,路由器再和校园外的另1台路由器连接,现做适当配置,实现校园网内部主机与校园网外部主机的相互通信。
本实验以两台R1762路由器、1台三层交换机为例。S3550上划分有VLAN10和VLAN50,其中VLAN10用于连接Router1,VLAN50用于连接校园网主机。
路由器分别命名为Router1和Router2,路由器之间通过串口采用V35 DCE/DTE电缆连接,DCE端连接到Router1(R1762)上。
PC1的IP地址和缺省网关分别为172.16.5.11和172.16.5.1,PC2的IP地址和缺省网关分别为172.16.3.22和172.16.3.1,网络掩码都是255.255.255.0。
【技术原理】
RIP(Routing Information Protocols,路由信息协议)是应用较早、使用较普遍的IGP(Interior Gateway Protocol,内部网关协议),适用于小型同类网络,是典型的距离矢量(distance-vector)协议。
RIP协议跳数做为衡量路径开销的,RIP协议里规定最大跳数为15。
RIP协议有两个版本RIPv1和RIPv2。
RIPv1属于有类路由协议,不支持VLSM(变长子网掩码),RIPv1是以广播的形式进行路由信息的更新的;更新周期为30秒。
RIPv2属于无类路由协议,支持VLSM(变长子网掩码),RIPv2是以组播的形式进行路由信息的更新的,组播地址是224.0.0.9。RIPv2还支持基于端口的认证,提高网络的安全性。
【实现功能】
实现网络的互连互通,从而实现信息的共享和传递。
【实验设备】
S3550交换机(1台)、R1762路由器(两台)、V35线缆(1根)、直连线或交叉线(1条)
【实验拓扑】

注:路由器和主机直连时,需要使用交叉线,在R1762的以太网接口支持MDI/MDIX,使用直连线也可以连通。R1的S1/2为DCE接口。
【实验步骤】
步骤20. 基本配置。
三层交换机基本配置
switch#configure terminal
switch(config)#hostname S3550
S3550(config)#vlan 10
S3550(config-vlan)#exit
S3550(config)#vlan 50
S3550(config-vlan)#exit
S3550(config)#interface f0/1
S3550(config-if)#switchport access vlan 10
S3550(config-if)#exit
S3550(config)#interface f0/5
S3550(config-if)#switchport access vlan 50
S3550(config-if)#exit
S3550(config)#interface vlan 10 !创建VLAN虚接口,并配置IP
S3550(config-if)#ip address 172.16.1.2 255.255.255.0
S3550(config-if)#no shutdown
S3550(config-if)#exit
S3550(config)#interface vlan 50 !创建VLAN虚接口,并配置IP
S3550(config-if)#ip address 172.16.5.1 255.255.255.0
S3550(config-if)#no shutdown
S3550(config-if)#exit
步骤21. 验证测试:
S3550#show vlan
VLAN Name Status Ports
———————————————————————-
1 default active Fa0/2 ,Fa0/3
Fa0/4 ,Fa0/6 ,Fa0/7
Fa0/8 ,Fa0/9 ,Fa0/10
Fa0/11,Fa0/12,Fa0/13
Fa0/14,Fa0/15,Fa0/16
Fa0/17,Fa0/18,Fa0/19
Fa0/20,Fa0/21,Fa0/22
Fa0/23,Fa0/24
10 vlan10 active Fa0/1
50 vlan50 active Fa0/5
S3550#show ip interface
Interface : VL10
Description : Vlan 10
OperStatus : UP
ManagementStatus : Enabled
Primary Internet address: 172.16.1.1/24
Broadcast address : 255.255.255.255
PhysAddress : 00d0.f8ff.8ab5
Interface : VL50
Description : Vlan 50
OperStatus : UP
ManagementStatus : Enabled
Primary Internet address: 172.16.5.1/24
Broadcast address : 255.255.255.255
PhysAddress : 00d0.f8ff.8ab6
路由器基本配置
Router1(config)# interface fastethernet 1/0
Router1(config-if)# ip address 172.16.1.1 255.255.255.0
Router1(config-if)# no shutdown
Router1(config-if)#exit
Router1(config)# interface serial 1/2
Router1(config-if)# ip address 172.16.2.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)# no shutdown
Router2(config)# interface fastethernet 1/0
Router2(config-if)# ip address 172.16.3.1 255.255.255.0
Router2(config-if)# no shutdown
Router2(config-if)#exit
Router2(config)# interface serial 1/2
Router2(config-if)# ip address 172.16.2.2 255.255.255.0
Router2(config-if)# no shutdown
验证测试:验证路由器接口的配置和状态。
Router1#show ip interface brief
Interface IP-Address(Pri) OK? Status
serial 1/2 172.16.2.1/24 YES UP
serial 1/3 no address YES DOWN
FastEthernet 1/0 172.16.1.1/24 YES UP
FastEthernet 1/1 no address YES DOWN
Null 0 no address YES UP
Router2#show ip interface brief
Interface IP-Address(Pri) OK? Status
serial 1/2 172.16.2.2/24 YES UP
serial 1/3 no address YES DOWN
FastEthernet 1/0 172.16.3.2/24 YES UP
FastEthernet 1/1 no address YES DOWN
Null 0 no address YES UP
步骤22. 配置RIP v2路由协议。
S3550配置RIP协议
S3550(config)#router rip !开启RIP协议进程
S3550(config-router)#network 172.16.1.0 !申明本设备的直连网段
S3550(config-router)#network 172.16.5.0
S3550(config-router)#version 2
Router1配置RIPv2协议
Router1(config)# router rip
Router1(config-router)#network 172.16.1.0
Router1(config-router)#network 172.16.2.0
Router1(config-router)#version2 !定义RIP协议v2
Router1(config-router)#no auto-summary !关闭路由信息的自动汇总功能
Router2配置RIP协议
Router2(config)# router rip
Router2(config-router)#network 172.16.2.0
Router2(config-router)#network 172.16.3.0
Router2(config-router)#version2
Router2(config-router)#no auto-summary
步骤23. 验证三台路由设备的路由表,查看是否自动学习了其他网段的路由信息。
S3550#show ip route
Type: C – connected, S – static, R – RIP, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
Type Destination IP Next hop Interface Distance Metric Status
———————————————————————-
C 172.16.1.0/24 0.0.0.0 VL10 0 0 Active
R 172.16.2.0/24 172.16.1.1 VL10 120 2 Active
R 172.16.3.0/24 172.16.1.1 VL10 120 3 Active
C 172.16.5.0/24 0.0.0.0 VL50 0 0 Active
Router1#show ip route
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
* – candidate default
Gateway of last resort is no set
C 10.1.1.2/32 is directly connected, serial 1/2
C 172.16.1.0/24 is directly connected, FastEthernet 1/0
C 172.16.1.1/32 is local host.
C 172.16.2.0/24 is directly connected, serial 1/2
C 172.16.2.1/32 is local host.
R 172.16.5.0/24 [120/1] via 172.16.1.2, 00:00:01, FastEthernet 1/0
R 172.16.3.0/24 [120/1] via 172.16.2.2, 00:00:21, serial 1/2
Router2#show ip route
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
* – candidate default
Gateway of last resort is no set
C 10.1.1.1/32 is directly connected, serial 1/2
R 172.16.1.0/24 [120/1] via 172.16.2.1, 00:00:03, serial 1/2
C 172.16.2.0/24 is directly connected, serial 1/2
C 172.16.2.2/32 is local host.
R 172.16.5.0/24 [120/2] via 172.16.2.1, 00:00:03, serial 1/2
步骤24. 测试网络的连通性。
C:\>ping 172.16.3.22 !从PC1 ping PC2

【注意事项】
* 1、在串口上配置时钟频率时,一定要在电缆DCE端的路由器上配置,否则链路不通。
* 2、No auto-summary功能只有在RIPv2支持。
* 3、S3550-24没有no auto-summary命令。
* 4、PC主机网关一定要指向直连接口IP地址,例如PC1网关指向三层交换机VLAN50的IP地址。
【参考配置】
S3550#show running-config

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*