Cisco路由器利用NAT实现外网主机访问内网服务器

NAT实现外网主机访问内网服务器

网络工程师Cisco路由器利用NAT实现外网主机访问内网服务器解析

【实验名称】
利用NAT实现外网主机访问内网服务器。
【实验目的】
掌握NAT源地址转换和目的地址转换的区别,掌握如何向外网发布内网的服务器
【背景描述】
你是某公司的网络工程师,公司只向ISP申请了一个公网IP地址,现公司的网站在内网,要求在互联网也可以访问公司网站,请你实现。172.16.8.5是Web服务器的IP地址。
【技术原理】
NAT(网络地址转换或网络地址翻译),是指将网络地址从一个地址空间转换为另一个地址空间的行为。
NAT将网络划分为内部网络(inside)和外部网络(outside)两部分。局域网主机利用NAT访问网络时,是将局域网内部的本地地址转换为了全局地址(互联网合法IP地址)后转发数据包。
NAT分为两种类型:NAT(网络地址转换)和NAPT(网络地址端口转换)。NAT是实现转换后一个本地IP地址对应一个全局地址。NAPT是实现转换后多个本地IP地址对应一个全局IP地址。目前网络中由于公网IP地址紧缺,而局域网主机数较多,因此一般使用动态的NAPT实现局域网多台主机共用一个或少数几个公网IP访问互联网。
【实现功能】
内网服务器能够转换成外网公网IP,被互联网访问。
【实验设备】
R1762 路由器(两台)、V.35线缆(1条)、PC(1台)、直连线(1条)
【实验拓扑】

图 36
【实验步骤】
步骤1. 基本配置。
Red-Giant(config)#hostname lan-router
lan-router(config)#interface fastEthernet 1/0
lan-router(config-if)#ip address 172.16.8.1 255.255.255.0
lan-router(config-if)#no shutdown
lan-router(config-if)#exit
lan-router(config)#interface serial 1/2
lan-router(config-if)#ip address 200.1.8.7 255.255.255.0
lan-router(config-if)#no shutdown
lan-router(config-if)#exit
internet-router(config)#interface fastEthernet 1/0
internet-router(config-if)#ip address 63.19.6.1 255.255.255.0
internet-router(config-if)#no shutdown
internet-router(config-if)#exit
internet-router(config)#interface serial 1/2
internet-router(config-if)#ip address 200.1.8.8 255.255.255.0
internet-router(config-if)#clock rate 64000
internet-router(config-if)#no sh
internet-router(config-if)#end
? 在lan-router上配置缺省路由
lan-router(config)#ip route 0.0.0.0 0.0.0.0 serial 1/2
验证测试:
Internet-router#ping 200.1.8.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 200.1.8.7, timeout is 2 seconds:
!!!!!
步骤2. 配置反向NAT映射。
lan-router(config)#interface fastEthernet 1/0
lan-router(config-if)#ip nat inside
lan-router(config-if)#exit
lan-router(config)#interface serial 1/2
lan-router(config-if)#ip nat outside
lan-router(config-if)#exit
lan-router(config)#ip nat pool web_server 172.16.8.5 172.16.8.5
netmask 255.255.255.0 ! 定义内网服务器地址池
lan-router(config)#access-list 3 permit host 200.1.8.7
!定义外网的公网IP地址
lan-router(config)#ip nat inside destination list 3 pool web_server
!将外网的公网IP地址转换为Web服务器地址。
lan-router(config)# ip nat inside source static tcp 172.16.8.5 80 200.1.8.7 80
!定义访问外网IP的80端口时转换为内网的服务器IP的80端口
步骤3. 验证测试。
1、在内网主机配置Web服务(详见选修实验内容)。
2、在外网的1台主机通过IE浏览器访问200.1.8.7。
lan-router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 200.1.8.7:80 172.16.8.5:80 63.19.6.2:1026 63.19.6.2:1026
【注意事项】
1、不要把inside和outside应用的接口弄错;
2、配置目标地址转换后,需要利用静态NAPT配置静态的端口地址转换。
【参考配置】
lan-router#show running-config
Building configuration…
Current configurat
!
version 8.32(building 53)
hostname lan-router
!
access-list 10 permit host 200.1.8.7
!!
interface serial 1/2
ip nat outside
ip address 200.1.8.7 255.255.255.0
clock rate 64000
! interface serial 1/3
clock rate 64000
!
interface FastEthernet 1/0
ip nat inside
ip address 172.16.8.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet 1/1
duplex auto
speed auto
!
interface Null 0
!
ip nat pool web_server 172.16.8.5 172.16.8.5 netmask 255.255.255.0
ip nat inside source static tcp 172.16.8.5 80 200.1.8.7 80
ip nat inside destination list 3 pool web_server
!
ip route 0.0.0.0 0.0.0.0 serial 1/2
!
line con 0
line aux 0
line vty 0 4
login
!
end

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*