Cisco路由器配置OSPF单区域

Cisco路由器配置OSPF单区域

网络工程师路由器配置OSPF单区域
【实验名称】
Cisco路由器配置OSPF单区域基本配置。
【实验目的】
掌握在路由器上配置OSPF单区域。
【背景描述】
假设校园网通过1台三层交换机连到校园网出口路由器,路由器再和校园外的另1台路由器连接,现做适当配置,实现校园网内部主机与校园网外部主机的相互通信。
本实验以两台R1762路由器、1台三层交换机为例。S3550上划分有VLAN10和VLAN50,其中VLAN10用于连接Router1,VLAN50用于连接校园网主机。
路由器分别命名为Router1和Router2,路由器之间通过串口采用V35 DCE/DTE电缆连接,DCE端连接到Router1(R1762)上。
PC1的IP地址和缺省网关分别为172.16.5.11和172.16.5.1,PC2的IP地址和缺省网关分别为172.16.3.22和172.16.3.1,网络掩码都是255.255.255.0。
【技术原理】
OSPF(Open Shortest Path First,开放式最短路径优先)协议,是目前网络中应用最广泛的路由协议之一。属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链路状态(link-state)协议。
OSPF路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库(LSDB),然后路由器采用SPF算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。
OSPF属于无类路由协议,支持VLSM(变长子网掩码)。OSPF是以组播的形式进行链路状态的通告的。
在大模型的网络环境中,OSPF支持区域的划分,将网络进行合理规划。划分区域时必须存在area0(骨干区域)。其他区域和骨干区域直接相连,或通过虚链路的方式连接。
【实现功能】
实现网络的互连互通,从而实现信息的共享和传递。
【实验设备】
S3550(1台)、R1762路由器(两台)、V35线缆(1根)、交叉线或直连线(1条)
注:路由器和主机直连时,需要使用交叉线,在R1762的以太网接口支持MDI/MDIX,使用直连线也可以连通。R1的S1/2为DCE接口。
【实验步骤】
步骤25. 基本配置。
三层交换机基本配置
switch#configure terminal
switch(config)#hostname s3550
S3550(config)#vlan 10
S3550(config-vlan)#exit
S3550(config)#vlan 50
S3550(config-vlan)#exit
S3550(config)#interface f0/1
S3550(config-if)#switchport access vlan 10
S3550(config-if)#exit
S3550(config)#interface f0/5
S3550(config-if)#switchport access vlan 50
S3550(config-if)#exit
S3550(config)#interface vlan 10 !创建VLAN虚接口,并配置IP
S3550(config-if)#ip address 172.16.1.2 255.255.255.0
S3550(config-if)#no shutdown
S3550(config-if)#exit
S3550(config)#interface vlan 50 !创建VLAN虚接口,并配置IP
S3550(config-if)#ip address 172.16.5.1 255.255.255.0
S3550(config-if)#no shutdown
S3550(config-if)#exit
步骤26. 验证测试:
S3550#show vlan

路由器基本配置
Router1(config)# interface fastethernet 1/0
Router1(config-if)# ip address 172.16.1.1 255.255.255.0
Router1(config-if)# no shutdown
Router1(config-if)#exit
Router1(config)# interface serial 1/2
Router1(config-if)# ip address 172.16.2.1 255.255.255.0
Router1(config-if)# clock rate 64000
Router1(config-if)# no shutdown
Router2(config)# interface fastethernet 1/0
Router2(config-if)# ip address 172.16.3.1 255.255.255.0
Router2(config-if)# no shutdown
Router2(config-if)#exit
Router2(config)# interface serial 1/2
Router2(config-if)# ip address 172.16.2.2 255.255.255.0
Router2(config-if)# no shutdown
验证测试:验证路由器接口的配置和状态。
Router1#show ip interface brief

步骤27. 配置OSPF路由协议。
S3550配置OSPF
步骤28. S3550(config)#router ospf !开启OSPF路由协议进程
S3550(config-router)#network 172.16.5.0 0.0.0.255 area 0
! 申请直连网段信息,并分配区域号
S3550(config-router)#network 172.16.1.0 0.0.0.255 area 0
S3550(config-router)#end
Router1配置OSPF
Router1(config)# router ospf
Router1(config-router)#network 172.16.1.0 0.0.0.255 area 0
Router1(config-router)#network 172.16.2.0 0.0.0.255 area 0
Router1(config-router)#end
Router2配置OSPF
Router2(config)#router ospf
Router2(config-router)#network 172.16.2.0 0.0.0.255 area 0
Router2(config-router)#network 172.16.3.0 0.0.0.255 area 0
Router2(config-router)#end
步骤29. 查看验证三台路由设备的路由表,查看是否自动学习了其他网段的路由信息。
S3550#show ip route

 

步骤30. 测试网络的连通性。
C:\>ping 172.16.3.22

 

【注意事项】
1、在串口上配置时钟频率时,一定要在电缆DCE端的路由器上配置,否则链路不通。
2、在申明直连网段时,注意要写该网段的反掩码。
3、在申明直连网段时,必须指明所属的区域。
【参考配置】
S3550# show running-config

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*