Cisco路由器配置RSTP的增强特性

网络工程师RSTP的增强特性

网络工程师RSTP的增强特性
【实验名称】
Cisco路由器配置RSTP的增强特性

【实验目的】
配置RSTP的计时器参数等特性,验证生成树配置。

【背景描述】
作为网络工程师,你在交换网络中配置了RSTP生成树协议,为了减少交换机发送BPDU报文对网络带宽的消耗,或者为了加快网络收敛,你可以修改RSTP计时器参数的缺省值。
本实验以2台S2126G交换机为例,两台交换机分别命名为SwitchA, SwitchB。假设PC1和PC2的IP地址分别为192.168.0.137/24和192.168.0.136/24 。

【实现功能】
减少交换机发送BPDU报文对网络带宽的消耗,或者加快交换网络的收敛。

【实验拓扑】
【实验设备】
S2126G(2台)

【实验步骤】

第一步:配置交换机SwitchA 的RSTP计时器参数
SwitchA(config)# spanning-tree !打开生成树
SwitchA(config)# spanning-tree mode rstp ! 采用生成树RSTP模式

SwitchA#show spanning-tree ! 显示交换机当前的计时器参数
StpVersion : RSTP
SysStpStatus : Enabled
BaseNumPorts : 24
MaxAge : 20 !BPDU报文的有效存活时间为20s(秒)
HelloTime : 2 !发送BPDU报文的时间间隔为2s
ForwardDelay : 15 !进入转发状态的时间为15s
BridgeMaxAge : 20
BridgeHelloTime : 2
BridgeForwardDelay : 15
MaxHops : 20
TxHoldCount : 3
PathCostMethod : Long
BPDUGuard : Disabled
BPDUFilter : Disabled
BridgeAddr : 00d0.f8fe.1e49
Priority : 32768
TimeSinceTopologyChange : 6d:5h:7m:49s
TopologyChanges : 0
DesignatedRoot : 800000D0F8FE1E49
RootCost : 0
RootPort : 0

SwitchA(config)# spanning-tree hello-time 4 ! 配置交换机发送BPDU报文的时间间隔为4s(秒),缺省为2s,范围是1—10s 。若要恢复到缺省值,用命令no spanning-tree hello-time

SwitchA(config)# spanning-tree forward-time 30 ! 配置进入转发状态的时间为20s,缺省为15s,范围是4—30s

SwitchA(config)# spanning-tree max-age 40 !配置BPDU报文的有效存活时间为40s,缺省为20s,范围是6—40s

验证测试:验证计时器参数配置
SwitchA#show spanning-tree
StpVersion : RSTP
SysStpStatus : Enabled
BaseNumPorts : 24
MaxAge : 40 !BPDU报文的有效存活时间为40s(秒)
HelloTime : 4 !发送BPDU报文的时间间隔为2s
ForwardDelay : 30 !进入转发状态的时间为30s
BridgeMaxAge : 40
BridgeHelloTime : 4
BridgeForwardDelay : 30
MaxHops : 20
TxHoldCount : 3
PathCostMethod : Long
BPDUGuard : Disabled
BPDUFilter : Disabled
BridgeAddr : 00d0.f8fe.1e49
Priority : 32768
TimeSinceTopologyChange : 0d:0h:4m:47s
TopologyChanges : 0
DesignatedRoot : 800000D0F8FE1E49
RootCost : 0
RootPort : 0

 

第二步:配置交换机SwitchB 的RSTP计时器参数
SwitchB(config)# spanning-tree !打开生成树
SwitchB(config)# spanning-tree mode rstp ! 采用生成树RSTP模式

SwitchB#show spanning-tree ! 显示交换机当前的计时器参数
StpVersion : RSTP
SysStpStatus : Enabled
BaseNumPorts : 24
MaxAge : 20
HelloTime : 2
ForwardDelay : 15
BridgeMaxAge : 20
BridgeHelloTime : 2
BridgeForwardDelay : 15
MaxHops : 20
TxHoldCount : 3
PathCostMethod : Long
BPDUGuard : Disabled
BPDUFilter : Disabled
BridgeAddr : 00d0.f8ef.9d09
Priority : 32768
TimeSinceTopologyChange : 0d:0h:1m:14s
TopologyChanges : 0
DesignatedRoot : 800000D0F8EF9D09
RootCost : 0
RootPort : 0

SwitchB(config)# spanning-tree hello-time 4 ! 配置交换机发送BPDU报文的时间间隔为4s(秒)
SwitchB(config)# spanning-tree forward-time 30 ! 配置进入转发状态的时间为20s
SwitchB(config)# spanning-tree max-age 40 !配置BPDU报文的有效存活时间为40s

验证测试:验证配置的计时器参数
SwitchB#show spanning-tree
StpVersion : RSTP
SysStpStatus : Enabled
BaseNumPorts : 24
MaxAge : 40
HelloTime : 4
ForwardDelay : 30
BridgeMaxAge : 40
BridgeHelloTime : 4
BridgeForwardDelay : 30
MaxHops : 20
TxHoldCount : 3
PathCostMethod : Long
BPDUGuard : Disabled
BPDUFilter : Disabled
BridgeAddr : 00d0.f8ef.9d09
Priority : 32768
TimeSinceTopologyChange : 0d:0h:2m:49s
TopologyChanges : 0
DesignatedRoot : 800000D0F8EF9D09
RootCost : 0
RootPort : 0

 

【注意事项】
一般不建议修改缺省的生成树计时器值,若在特殊情况下需要修改,则应保证在同一网络中各交换机的参数配置为相同的值;
将整个spanning-tree恢复为缺省状态用命令spanning-tree reset 。

 

【参考配置】
SwitchA#show run ! 交换机SwithA的全部配置
Building configuration…
Current configuration : 374 bytes
!
version 1.0
!
hostname SwitchA
enable secret level 1 5 $21X)sv’3H.Y*T7+4,tZ[V/,Q+S(\W&-
enable secret level 15 5 $2in’.tj3fjo+/7R4gkE,1u_Qhl&-8U0
!
spanning-tree mode rstp
spanning-tree
spanning-tree forward-time 30
spanning-tree hello-time 4
spanning-tree max-age 40
interface vlan 1
no shutdown
ip address 192.168.0.1 255.255.255.0
!
end

SwitchB#show run ! 交换机SwithB的全部配置
uilding configuration…
Current configuration : 374 bytes
!
version 1.0
!
hostname SwitchB
enable secret level 1 5 $2@IOrJ%3mLMp]K*4nAxB^”[QowNq&#Z
enable secret level 15 5 $2-/-aeh3’~1’dfi4+.t{bckQ,|7zygl
!
spanning-tree mode rstp
spanning-tree
spanning-tree forward-time 30
spanning-tree hello-time 4
spanning-tree max-age 40
interface vlan 1
no shutdown
ip address 192.168.0.2 255.255.255.0
!
end

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*