网络工程师防止指定路由器路由更新

网络工程师防止指定路由器路由更新

网络工程师防止指定路由器路由更新
【实验名称】
Cisco路由器配置防止指定路由器路由更新

【实验目的】
通过配置passive interface来防止指定路由器路由更新

【背景描述】
你是一名高级网络工程师,现有一网络扩建工程如下,某公司业务拓展,收购了另外一公司,新收购的公司由于还没有交割清楚,总公司决定只允许新公司发送路由更新,总公司自身路由信息不发送给新公司,但是总公司和原来已有的子公司要正常更新路由信息,两子公司之间也可交互路由信息,请你实现。R3代表总公司,R1代表新公司,R2代表老子公司。

【实现功能】
通过指定路由器路由更新,控制路由信息的传输。

【实验拓扑】
【实验设备】
R2624路由器(3台)、V35DCE(2根)、V35DTE(2根)

【实验步骤】

第一步:基本配置
Red-Giant#configure t
Red-Giant(config)#hostname R1 !配置主机名
R1(config)# interface fastethernet 0
R1(config-if)#ip address 192.168.123.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#interface loopback 0 !声明一个回环接口,模拟一个网段
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#end

Red-Giant#configure t
Red-Giant(config)#hostname R2
R2(config)# interface fastethernet 0
R2(config-if)#ip address 192.168.123.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#interface loopback 0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#end

Red-Giant#configure t
Red-Giant(config)#hostname R3
R3(config)# interface fastethernet 0
R3(config-if)#ip address 192.168.123.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#interface loopback 0
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#end

验证测试: R2#ping 192.168.123.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.168.123.1, timeout is 2 seconds:
!!!!!
R3#ping 192.168.123.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.168.123.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
R3#ping 192.168.123.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.168.123.2, timeout is 2 seconds:
!!!!!

第二步:配置路由协议及对指定路由器控制
R3(config)#router rip ! 启动RIP路由协议
R3(config-router)#version 2 !设置RIP版本
R3(config-router)#net 192.168.123.0 !声明RIP路由协议的网段
R3(config-router)#net 192.168.3.0
R3(config-router)#passive-interface fastEthernet 0 !在fastEthernet 0接口只接受路由更新,不发送路由更新
R3(config-router)#neighbor 192.168.123.2 !可以与邻居192.168.123.2交互路由信息
R3(config-router)#end

R2(config)#router rip
R2(config-router)#ver 2
R2(config-router)#net 192.168.123.0
R2(config-router)# net 192.168.2.0
R2(config-router)#end

R1(config)#router rip
R1(config-router)#net 192.168.123.0
R1(config-router)#net 192.168.3.0
R1(config-router)#ver 2
R1(config-router)#end

验证测试:R1#sh ip route
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.123.0/24 is directly connected, FastEthernet0
C 192.168.1.0/24 is directly connected, Loopback0
R 192.168.2.0/24 [120/1] via 192.168.123.2, 00:00:05, FastEthernet0
R2#sh i p route
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.123.0/24 is directly connected, FastEthernet0
R 192.168.1.0/24 [120/1] via 192.168.123.1, 00:00:02, FastEthernet0
C 192.168.2.0/24 is directly connected, Loopback0
R 192.168.3.0/24 [120/1] via 192.168.123.3, 00:00:02, FastEthernet0

R3#sh ip ro
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.123.0/24 is directly connected, FastEthernet0
R 192.168.1.0/24 [120/1] via 192.168.123.1, 00:00:13, FastEthernet0
R 192.168.2.0/24 [120/1] via 192.168.123.2, 00:00:13, FastEthernet0
C 192.168.3.0/24 is directly connected, Loopback0

【注意事项】
注意rip路由协议的版本
注意声明要与自己通信的邻居

【参考配置】
R3# sh run
Building configuration…

Current configuration:
!
version 6.14(2)
!
hostname “R3”
!
ip subnet-zero
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0
ip address 192.168.123.3 255.255.255.0
!
interface FastEthernet1
no ip address
shutdown
interface FastEthernet2
no ip address
shutdown

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*