Cisco交换机配置利用TFPT备份还原文件命令

Cisco交换机配置利用TFPT备份还原文件命令

Cisco交换机利用TFPT备份还原交换机配置文件命令
【实验目的】
能够从TFTP服务器备份、恢复设备配置。
【背景描述】
假设某台交换机的配置文件由于误操作或其他某种原因被破坏了,现在需要从TFTP服务器上的备份配置文件中恢复。
本实验以1台S2126G交换机为例,交换机名为SwitchA。1台PC机通过串口(Com)连接到交换机的控制(Console)端口,通过网卡(NIC)连接到交换机的fastethernet 0/1端口。假设PC机的IP地址和网络掩码分别为192.168.0.137,255.255.255.0,PC机上已安装和打开了TFTP Server程序,且在PC机已经准备好了新的交换机操作系统。
【实现功能】
使网络工程师可以备份配置文件,并且将配置恢复到交换机上。
【实验设备】
S2126G(1台)、直连线(1条)
【实验拓扑】
【实验步骤】
步骤1. 在交换机上配置管理接口IP地址。
SwitchA(config)# interface vlan 1 !进入交换机管理接口配置模式
SwitchA(config-if)# ip address 192.168.0.138 255.255.255.0
!配置交换机管理接口IP地址
SwitchA(config-if))# no shutdown !开启交换机管理接口
验证测试:验证交换机管理IP地址配置和开启,TFTP服务器与交换机有网络连通性。
SwitchA#show ip interface
Interface : VL1
Description : Vlan 1
OperStatus : up
ManagementStatus : Enabled
Primary Internet address: 192.168.0.138/24
Broadcast address : 255.255.255.255
PhysAddress : 00d0.f8fe.1e48
SwitchA#ping 192.168.0.137 !验证交换机与TFTP服务器具有网络连通性
Sending 5, 100-byte ICMP Echos to 192.168.0.137,
timeout is 2000 milliseconds.
!!!!!
Success rate is 100 percent (5/5)
Minimum = 1ms Maximum = 2ms, Average = 1ms
步骤2. 备份交换机配置文件。
在主机上开启TFTP服务工具,并指定根目录。
SwitchA#copy running-config startup-config ! 保存交换机的当前配置
SwitchA#copy startup-config tftp ! 备份交换机配置到TFTP服务器
Address of remote host []192.168.0.137 ! 按提示输入TFTP服务器IP地址
Destination filename [config.text]? ! 选择要保存的配置文件名称
!
%Success : Transmission success,file length 302
验证测试:验证已保存配置文件。
打开TFTP服务器上的配置文件C:\config.text,文件内容显示如下:
!
version 1.0
!
hostname SwitchA
enable secret level 1 5 $2)sv’~13Y*T7+.t4Z[V/,|7Q(\W&-/-
enable secret level 15 5 $2Nq&#Z13IOrJ%(84Mp]K*.tQxB^”[/7
!
interface fastEthernet 0/5
switchport access vlan 10
!
interface vlan 1
no shutdown
ip address 192.168.0.138 255.255.255.0
!
end
步骤3. 从主机恢复交换机配置。
switchA#delete flash:config.text !删除原有的配置文件
SwitchA#copy tftp startup-config ! 加载配置到交换机的初始配置文件中
Source filename []?config.text !按提示输入源文件名
Address of remote host []192.168.0.137 !按提示输入TFTP服务器的IP地址
%Success : Transmission success,file length 302
验证测试:验证交换机已经更改为新的配置。
SwitchA#show configure ! 验证交换机的初始配置文件
Using 302 out of 4194304 bytes
!
version 1.0
!
hostname SwitchA
enable secret level 1 5 $2)sv’~13Y*T7+.t4Z[V/,|7Q(\W&-/-
enable secret level 15 5 $2Nq&#Z13IOrJ%(84Mp]K*.tQxB^”[/7
!
interface fastEthernet 0/5
switchport access vlan 10
!
interface vlan 1
no shutdown
ip address 192.168.0.138 255.255.255.0
!
end
步骤4. 重启交换机,使新的配置生效。
SwitchA#reload ! 重启交换机
System configuration has been modified. Save? [yes/no]:n !选择no
Proceed with reload? [confirm]
【注意事项】
在恢复配置到交换机上之前,须验证交换机与PC机(TFTP Server)具有网络连通性。
【参考配置】
SwitchA#show running-config
Building configuration…
Current configuration : 302 bytes
!
version 1.0
!
hostname SwitchA
enable secret level 1 5 $2>H.Y*T3;C,tZ[V4<D+S(\WQ=G1X)sv
enable secret level 15 5 $2tj9=G13/7R:>H.41u_;C,tQ8U0<D+S
!
interface fastEthernet 0/5
switchport access vlan 10
!
interface vlan 1
no shutdown
ip address 192.168.0.138 255.255.255.0
!
end

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*