Cisco路由器配置动态NAPT实现局域网访问互联网

Cisco路由器配置利用动态NAPT实现局域网访问互联网

Cisco路由器配置利用动态NAPT实现局域网访问互联网

【实验名称】
Cisco路由器配置利用动态NAPT实现局域网访问互联网。
【实验目的】
掌握内网中所有主机连接到Internet网时,通过端口号区分的复用内部全局地址转换。
【背景描述】
你是某公司的网络工程师,公司只向ISP申请了一个公网IP地址,希望全公司的主机都能访问外网,请你实现。
【技术原理】
NAT(网络地址转换或网络地址翻译),是指将网络地址从一个地址空间转换为另一个地址空间的行为。
NAT将网络划分为内部网络(inside)和外部网络(outside)两部分。局域网主机利用NAT访问网络时,是将局域网内部的本地地址转换为了全局地址(互联网合法IP地址)后转发数据包。
NAT分为两种类型:NAT(网络地址转换)和NAPT(网络地址端口转换)。NAT是实现转换后一个本地IP地址对应一个全局地址。NAPT是实现转换后多个本地IP地址对应一个全局IP地址。目前网络中由于公网IP地址紧缺,而局域网主机数较多,因此一般使用动态的NAPT实现局域网多台主机共用一个或少数几个公网IP访问互联网。
【实现功能】
允许内部所有主机在公网地址缺乏的情况下可以访问外部网络。
【实验设备】
R1762 路由器(两台)、V.35线缆(1条)、PC(两台)、直连线或交叉线(2条)
【实验拓扑】
【实验步骤】
步骤1. 基本配置。
局域网路由器配置
Red-Giant(config)#hostname lan-router
lan-router(config)#interface fastEthernet 1/0
lan-router(config-if)#ip address 172.16.1.1 255.255.255.0
lan-router(config-if)#no shutdown
lan-router(config-if)#exit
lan-router(config)#interface serial 1/2
lan-router(config-if)#ip address 200.1.8.7 255.255.255.0
lan-router(config-if)#no shutdown
lan-router(config-if)#exit
互联网路由器配置
internet-router(config)#interface fastEthernet 1/0
internet-router(config-if)#ip address 63.19.6.1 255.255.255.0
internet-router(config-if)#no shutdown
internet-router(config-if)#exit
internet-router(config)#interface serial 1/2
internet-router(config-if)#ip address 200.1.8.8 255.255.255.0
internet-router(config-if)#clock rate 64000
internet-router(config-if)#no sh
internet-router(config-if)#end
在lan-router上配置缺省路由
lan-router(config)#ip route 0.0.0.0 0.0.0.0 serial 1/2
验证测试:
Internet-router#ping 200.1.8.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 200.1.8.7, timeout is 2 seconds:
!!!!!
步骤2. 配置动态NAPT映射。
lan-router(config)#interface fastEthernet 1/0
lan-router(config-if)#ip nat inside !定义F1/0为内网接口
lan-router(config-if)#exit
lan-router(config)#interface serial 1/2
lan-router(config-if)#ip nat outside !定义S1/2为外网接口
lan-router(config-if)#exit
lan-router(config)#ip nat pool to_internet 200.1.8.7 200.1.8.7 netmask 255.255.255.0
! 定义内部全局地址池
lan-router(config)#access-list 10 permit 172.16.1.0 0.0.0.255
!定义允许转换的地址
lan-router(config)#ip nat inside source list 10 pool to_internet overload
!为内部本地调用转换地址池
步骤3. 验证测试。
1、在服务器63.19.6.2上配置Web服务(配置方法详见选修实验)。
2、在PC机测试访问63.19.6.2的网页。
3、在路由器lan-router查看NAPT映射关系。
lan-router#show ip nat translations !查看NAPT的动态映射表
Pro Inside global Inside local Outside local Outside global
tcp 200.1.8.7:2502 172.16.1.55:2502 63.19.6.2:80 63.19.6.2:80
【注意事项】
1、不要把inside和outside应用的接口弄错;
2、要加上能使数据包向外转发的路由,比如默认路由;
3、尽量不要用广域网接口地址作为映射的全局地址,本例子中特定仅有一个公网地址,实际工作中不推荐。
【参考配置】
lan-router#show running-config

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*