Cisco路由器配置路由三级网综合实验

路由三级网综合实验

Cisco路由器配置路由三级网综合实验

【实验名称】
Cisco路由器配置路由三级网综合实验。
【实验目的】
构建路由网络的三级结构。
【背景描述】
你是某系统集成公司的网络工程师,公司现在承接一个某金融机构网络的建设项目,客户要求网络设计分成省行、地市行、县级网点三级结构,并通过网络能够实现省行与县级网点的业务通讯及语音电话,经过与客户的充分沟通,现你设计的项目方案已经得到客户的认可,请你负责整个网络的实施。
【实现功能】
通过合理的三层网络架构,快捷满足客户需求。
【实验设备】
RG-S2126G(两台)、RG-S3760-48(两台)、RG-R1762(4台)、语音模块(2块)
【网络拓扑原型】
客户需求】
整个网络采用省行、地市行、县级网点三级结构,保证三级网络之间的数据能够正常传输,并且通过VoIP技术实现县级网点与省行直接通话的功能。
【实验拓扑说明】
整个实验用RG-S2126G1模拟县级网点用户接入交换机。
RG-S2126G2与RG-3760-48-1模拟地市行用户接入交换机RG-S3760-48-2模拟省行用户接入交换机;R1模拟县级网点接入路由器,R2与R3模拟地市行接入路由器,R4模拟省行接入路由器,其中R1与R4路由器上分别加语音模块用来完成VoIP的需求。
【IP地址规划】
设备名称 VLAN/端口名称 IP地址 端口连接状况
R1 Fastethernet1/0 191.16.1.1/24 F1/0—RG-2126G1—F0/1
Serial1/2 (DTE) 191.1.12.1/24 S1/2—R2 S1/2
R2 Serial1/2 (DCE) 191.1.12.2/24 S1/2—R1 S1/2
Serial1/3 (DTE) 191.1.24.1/24 S1/3—R4 S1/2
Fastethernet1/0 191.16.2.1/24 F1/0—RG-2126G2—F0/1

Cisco路由器配置路由三级网综合实验

(续表)
设备名称 VLAN/端口名称 IP地址 端口连接状况
R3 Serial1/3 (DTE) 191.1.34.1/24 S1/3—R4 S1/3
Fastethernet1/0 191.16.3.1/24 F1/0—RG-S3760-48-1—F0/1
R4 Serial1/2 (DCE) 191.1.24.2/24 S1/2—R2 S1/3
Serial1/3 (DCE) 191.1.34.2/24 S1/3—R3 S1/3
Fastethernet1/0 191.16.4.1/24 F1/0—RG-S3760-48-2—F0/1
Voice-port R1 voice-port 号码111111 Port 2/0
R4 voice-port 号码222222 Port 2/0
【基本配置】
步骤1. RG-S2126G-1、RG-S2126G-2、RG-3760-48-1、RG-3760-48-2无需配置,用于模拟用户接入。
步骤2. R1基本配置。
Red-Giant>en
Red-Giant#conf t
Red-Giant(config)#host R1
R1(config)#interface s 1/2
R1(config-if)#ip address 191.1.12.1 255.255.255.0
R1(config-if)# encapsulation PPP
R1(config-if)#no shu
R1(config-if)#exit
R1(config)#int fa0/1
R1(config-if)#ip address 191.16.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
步骤3. R2基本配置。
Red-Giant>en
Red-Giant#conf t
Red-Giant(config)#host R2
R2(config)#interface s 1/2
R2(config-if)#ip address 191.1.12.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)# encapsulation PPP
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int s1/3
R2(config-if)#ip add 192.1.24.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int fa0/1
R2(config-if)#ip address 191.16.2.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#exit
步骤4. R3基本配置。
Red-Giant>en
Red-Giant#conf t
Red-Giant(config)#host R3
R3(config)#int
R3(config)#interface s 1/3
R3(config-if)#ip address 191.1.34.1 255.255.255.0
R3(config-if)# encapsulation PPP
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int fa0/1
R3(config-if)#ip address 191.16.3.1 255.255.255.0
R3(config-if)#no sh
R3(config-if)#exit
步骤5. R4基本配置。
Red-Giant>en
Red-Giant#conf t
Red-Giant(config)#host R4
R4(config)#int
R4(config)#interface s 1/2
R4(config-if)#ip address 191.1.24.2 255.255.255.0
R4(config-if)#clock rate 64000
R4(config-if)# encapsulation PPP
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#int
R4(config)#interface s 1/3
R4(config-if)#ip address 191.1.34.2 255.255.255.0
R4(config-if)#clock rate 64000
R4(config-if)# encapsulation PPP
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#int fa0/1
R4(config-if)#ip address 191.16.4.1 255.255.255.0
R4(config-if)#no sh
R4(config-if)#exit
【路由配置】
步骤1. R1路由配置。
R1(config)#router ospf
R1(config-router)#net 191.1.12.0 0.0.0.255 area 1
R1(config-router)#net 191.16.1.0 0.0.0.255 area 1
R1(config-router)#exit
步骤2. R2路由配置。
R2(config)#router ospf
R2(config-router)#net 191.1.12.0 0.0.0.255 area 1
R2(config-router)#net 191.1.24.0 0.0.0.255 area 0
R2(config-router)#net 191.16.2.0 0.0.0.255 area 2
步骤3. R3路由配置。
R3(config)#router ospf
R3(config-router)#net 191.1.34.0 0.0.0.255 area 0
R3(config-router)#net 191.16.3.0 0.0.0.255 area 3
步骤4. R4路由配置。
R4(config)#router ospf
R4(config-router)#net 191.1.24.0 0.0.0.255 area 0
R4(config-router)#net 191.1.34.0 0.0.0.255 area 0
R4(config-router)#net 191.16.4.0 0.0.0.255 area 4
【VoIP配置】
步骤1. R4语音模块配置。
R4(config)#dial-peer voice 1 pots
R4(config-dial-peer)#destination-pattern 222222
R4(config-dial-peer)#port 2/0
R4(config-dial-peer)#exit
R4(config)#dial-peer voice 2 voip
R4(config-dial-peer)#destination-pattern 111111
R4(config-dial-peer)#session target ipv4: 191.1.12.1
R4(config-dial-peer)#end
步骤2. R1语音模块配置。
R1(config)#dial-peer voice 11 pots
R1(config-dial-peer)#destination-pattern 111111
R1(config-dial-peer)#port 2/0
R1(config-dial-peer)#exit
R1(config)#dial-peer voice 12 voip
R1(config-dial-peer)#destination-pattern 222222
R1(config-dial-peer)#session target ipv4: 191.1.24.2
R1(config-dial-peer)#end
【注意事项】
1、 注意语音模块的编号从0开始,先写模块号,后写接口编号。
2、 在配置拨号对等体时要注意配置本端及对端的电话号码。
3、 路由器同步口均封装PPP,要注意两端协调一致。
4、 所有IP地址要正确,并声明在相应的OSPF区域中。
【参考配置】
R1#sh run
R2#sh run
R3#sh run
R4#sh run

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*