Cisco路由器配置OSPF的路由汇总

Cisco路由器配置OSPF的路由汇总

Cisco路由器配置OSPF的路由汇总
【实验名称】
Cisco路由器配置OSPF的路由汇总

【实验目的】
掌握OSPF的域间路由汇总。

【背景描述】
一个企业的网络工程师请教你一个问题,他的网络的路由器接收了多条地址连续路由,他想让路由器提高工作效率,缩小路由表规模,请你给予支持。

【实现功能】
减少OSPF路由协议路由表的大小。

【实验拓扑】
【实验设备】
R2624路由器(2台)、V35DCE(1根)、V35DTE(1根)

【实验步骤】

第一步:基本配置
Red-Giant>en
Red-Giant#conf t
Red-Giant(config)#hostname R1
R1(config)#interface serial 0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config)#interface loopback 0
R1(config-if)#ip add 172.16.1.1 255.255.255.0
R1(config-if)#exi
R1(config)#int loo 1
R1(config-if)#ip address 172.16.2.1 255.255.255.0
Red-Giant>enable
Red-Giant#conf t
Red-Giant(config)#hostname R2
R2(config)#interface s0
R2(config-if)#ip add 192.168.12.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#end
验证测试:

第二步:配置OSPF路由协议
R1(config)#router ospf 1
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config-router)#network 172.16.1.0 0.0.0.255 area 2
R1(config-router)#network 172.16.2.0 0.0.0.255 area 2
R2(config)#router os 1
R2(config-router)#net 192.168.12.0 0.0.0.255 area 0

验证测试:R2#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface
172.16.2.1 1 FULL/ – 00:00:36 192.168.12.1 Serial0

第三步:区域间汇总路由
R1(config-router)#area 2 range 172.16.0.0 255.255.252.0 !配置区域间汇聚路由

验证测试:
R2#sh ip ro
Codes: C – connected, S – static, R – RIP
O – OSPF, IA – OSPF inter area
E1 – OSPF external type 1, E2 – OSPF external type 2

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0
C 192.168.12.0/24 is directly connected, Serial0
172.16.0.0/22 is subnetted, 1 subnets
O IA 172.16.0.0 [110/49] via 192.168.12.1, 00:00:01, Serial0

【注意事项】
注意汇总地址的掩码。

【参考配置】
R2#sh run

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*