Cisco路由器配置通过路由器实现VLAN间路由

通过路由器实现VLAN间路由

Cisco路由器配置通过路由器实现VLAN间路由
【实验名称】
Cisco路由器配置通过路由器实现VLAN间路由

【实验目的】
掌握如何通过路由器实现VLAN间路由。

【背景描述】
作为企业的网络工程师,你按企业的部门结构创建了多个VLAN,为了实现数据资源的共享,现在需要使不同的VLAN里的用户相互通信,于是你决定配置路由器来实现VLAN间路由。
本实验以1台S2126G交换机和1台R2620路由器为例,PC1和PC2的IP地址分别为192.168.10.10/24,192.168.20.20/24,PC1和PC2分别属于Vlan10和Vlan 20,缺省网关分别指定为Vlan10和Vlan 20在路由器上的对应子接口的IP地址192.168.10.1和192.168.20.1 。

【实现功能】
使位于不同VLAN里的用户可以相互通信。

【实验拓扑】
【实验设备】
S2126G(1台)、R2620(1台)

【实验步骤】

第一步:在交换机S2126G上创建Vlan 并分配相应端口
S2126G (config)# vlan 10 !创建Vlan 10
S2126G (config)# vlan 20 !创建Vlan 20

S2126G(config)#interface fastethernet 0/1 !进入接口配置模式
S2126G(config-if)#switchport access vlan 10 !将F0/1端口分配给Vlan 10

S2126G(config)#interface fastethernet 0/2 !进入接口配置模式
S2126G(config-if)#switchport access vlan 20 !将F0/2端口分配给Vlan 20

S2126G(config)#interface fastethernet 0/23
S2126G(config-if)#switchport mode trunk ! 配置trunk端口

验证测试:验证VLAN和Trunk配置
S2126G #show vlan
VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/3 ,Fa0/4 ,Fa0/5
Fa0/6 ,Fa0/7 ,Fa0/8
Fa0/9 ,Fa0/10,Fa0/11
Fa0/12,Fa0/13,Fa0/14
Fa0/15,Fa0/16,Fa0/17
Fa0/18,Fa0/19,Fa0/20
Fa0/21,Fa0/22,Fa0/23
Fa0/24
10 VLAN0010 active Fa0/1 ,Fa0/23
20 VLAN0020 active Fa0/2 ,Fa0/23

S2126G #show interface fastethernet 0/23 switchport ! 验证端口的完整配置
Interface Switchport Mode Access Native Protected VLAN lists
———- ———- ——— ——- ——– ——— ——————–
Fa0/23 Enabled Trunk 1 1 Disabled All


S2126G #show interface fastethernet 0/23 trunk ! 显示端口的trunk设置
Interface Mode Native VLAN VLAN lists
——————– —— ———– ——————–
Fa0/23 On 1 All

第二步:在R2620路由器上配置接口F0的子接口
R2620(config)# interface fastethernet 0
R2620(config-if)#no ip address
R2620(config-if)#no shutdown

R2620(config)# interface fastethernet 0.10 !进入子接口F0.10配置模式
R2620(config-if)# ip address 192.168.10.1 255.255.255.0 ! 配置子接口F0.10 IP地址
R2620(config-if)#encapsulation dot1q 10 ! 封装802.1Q并指定Vlan号10

R2620(config)# interface fastethernet 0.20 !进入子接口F0.20配置模式
R2620(config-if)# ip address 192.168.20.1 255.255.255.0 ! 配置子接口F0.20 IP地址
R2620(config-if)#encapsulation dot1q 20 ! 封装802.1Q并指定Vlan号20

验证测试:验证接口配置和VLAN配置
R2620#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0 unassigned YES unset up up
FastEthernet0.10 192.168.10.1 YES manual up up
FastEthernet0.20 192.168.20.1 YES manual up up
Serial0 unassigned YES unset administratively down down
Serial1 unassigned YES unset administratively down down

R2620#show vlans
Virtual LAN ID: 10 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: FastEthernet0.10
Protocols Configured: Address: Received: Transmitted:
IP 192.168.10.1 26 26
Virtual LAN ID: 20 (IEEE 802.1Q Encapsulation)
vLAN Trunk Interface: FastEthernet0.20
Protocols Configured: Address: Received: Transmitted:
IP 192.168.20.1 0 0

第三步:测试VLAN间路由
(下面以PC1 Ping PC2的结果为例加以说明)
C:\>ping 192.168.20.20 !在PC1的命令行方式下验证能Ping通PC3

以上结果显示说明:在不同VLAN里的计算机系统通过路由器是可以互相通信的。

【注意事项】
各个VLAN内主机的网关须指定为路由器上对应的子接口IP地址
路由器可以配置的带802.1Q封装的子接口数最多256个

【参考配置】
S2126G#show running-config ! 显示交换机S2126G的全部配置
R2620#show running-config ! 显示路由器R2620的全部配置

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*