Cisco路由器单臂路由配置及应用

Cisco单臂路由配置命令

网络工程师路由器单臂路由配置及应用

新建packer tracer拓扑图
实验设备
PC 2台;Router_2811 1台;Switch_2960 1台

2) 当交换机设置两个Vlan时,逻辑上已经成为两个网络,广播被隔离了。两个Vlan
的网络要通信,必须通过路由器,如果接入路由器的一个物理端口,则必须有两个
子接口分别不两个 Vlan 对应,同时还要求不路由器相连得交换机的端口 fa 0/24
要设置为trunk,因为这个接口要通过两个Vlan的数据包。
3) 检查设置情况,应该能够正确的看到Vlan和Trunk信息。

4) 计算机的网关分别指向路由器的子接口。
5) 配置子接口,开启路由器物理接口。
6) 默认封装dot1q协议。
7) 配置路由器子接口IP地址

S1配置 
Switch>en 
Switch#conf t 
Switch(config)#hostname S1 
 
S1(config)#vlan 2 
S1(config-vlan)#exit 
S1(config)#vlan 3 
S1(config-vlan)#exit 
 
S1(config)#interface fa 0/1 
S1(config-if)#switchport access vlan 2 
S1(config-if)#exit 
 
S1(config)#interface fa 0/2 
S1(config-if)#switchport access vlan 3 
S1(config-if)#exit 
 
S1(config)#interface fa 0/24 
S1(config-if)#switchport mode trunk 
S1(config-if)#exit 
S1(config)#end 
查看S1 
S1#show run

 

 

R1配置 
Continue with configuration dialog? [yes/no]: n 
Press RETURN to get started! 
Router>en 
Router#conf t 
Router(config)#hostname R1 
 
R1(config)#interface fastEthernet 0/0 
R1(config-if)#no shutdown 
 
R1(config)#interface fastEthernet 0/0.1 // 配置子接口 
R1(config-subif)#encapsulation dot1Q 2 //在路由器上配置trunk的封装协议的命令 
R1(config-subif)#ip address 192.168.1.1 255.255.255.0 
R1(config-subif)#exit 
 
R1(config)#interface fastEthernet 0/0.2 // 配置子接口 
R1(config-subif)#encapsulation dot1Q 3 //在路由器上配置trunk的封装协议的命令 
R1(config-subif)#ip address 192.168.2.1 255.255.255.0 
R1(config-subif)#end 
查看R1 
R1#show ip route

 

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*