Cisco路由器配置RIP路由配置

Cisco路由器RIP配置命令

网络工程师配置RIP路由配置

RIP路由配置
拓扑及实验要求
实验目的
 掌握RIP协议的配置方法;
 掌握查看通过劢态路由协议RIP学习产生的路由;
 熟悉广域网线缆的链接方式;

技术原理
 RIP(Routing Information Protocol,路由信息协议)是应用较早、使用较普遍的
IGP内部网管协议,使用于小型同类网络,是距离矢量协议;
 RIP协议跳数作为衡量路径开销的,RIP协议里规定最大跳数为15;
 RIP 协议有两个版本:RIPv1 和 RIPv2,RIPv1 属于有类路由协议,丌支持
VLSM(可变长子网掩码),以广播形式迚行路由信息的更新,更新周期为 30 秒;
RIPv2属于无类路由协议,支持VLSM,以组播形式迚行路由更细。
实验步骤
1) 建立建立packet tracer拓扑图。
2) 在本实验中的三层交换机上划分VLAN10和VLAN20,其中VLAN10用于连接校
园网主机,VLAN20用于连接R1。
3) 路由器之间通过 V.35 电缆通过串口连接,DCE端连接在 R1 上,配置其时钟频率
64000。
4) 主机和交换机通过直连线,主机不路由器通过交叉线连接。
5) 在S3560上配置 RIPV2路由协议。
6) 在路由器R1、R2 上配置RIPV2路由协议。
7) 将PC1、PC2主机默认网关设置为不直连网路设备接口IP地址。
8) 验证PC1、PC2主机之间可以互相同信。
实验设备
PC 2台;Switch_3560 1台;Router-PT 2台;直连线;交叉线;DCE 串口线

S1配置 
 
Switch>en 
Switch #conf t 
Switch (config)#hostname S1 
 
S1(config)#vlan 10 
S1(config-vlan)#exit 
 
S1(config)#vlan 20 
S1(config-vlan)#exit 
 
S1(config)#interface fastEthernet 0/10 
S1(config-if)#switchport access vlan 10 
S1(config-if)#exit 
 
S1(config)#interface fastEthernet 0/20 
S1(config-if)#switchport access vlan 20 
S1(config-if)#exit 
 
S1(config)#interface vlan 10 
S1(config-if)#ip address 192.168.1.1 255.255.255.0 
S1(config-if)#no shutdown 
S1(config-if)#exit 
 
S1(config)#interface vlan 20 
S1(config-if)#ip address 192.168.3.1 255.255.255.0 
S1(config-if)#no shutdown 
S1(config-if)#exit 
 
S1(config)#ip routing //开启三层交换机的路由功能 
S1(config)#router rip 
S1(config-router)#network 192.168.1.0 
S1(config-router)#network 192.168.3.0 
S1(config-router)#version 2 
S1(config-router)#end 
 
 
查看S1 
S1#show vlan
R1配置 
Router>en 
Router#conf t 
Router(config)#hostname R1 
 
R1(config)#interface fastEthernet 0/0 
R1(config-if)#ip address 192.168.3.2 255.255.255.0 
R1(config-if)#no shutdown 
R1(config-if)#exit 
 
R1(config)#interface serial 2/0 
R1(config-if)#no shutdown 
R1(config-if)#ip address 192.168.4.1 255.255.255.0 
R1(config-if)#clock rate 64000 
R1(config-if)#exit 
 
R1(config)#router rip 
R1(config-router)#network 192.168.3.0 
R1(config-router)#network 192.168.4.0 
R1(config-router)#version 2 
R1(config-router)#end 
查看R1 
R1#show ip route

 

R2配置 
Router>en 
Router#conf t 
Router(config)#hostname R2 
 
R2(config)#interface fastEthernet 0/0 
R2(config-if)#ip address 192.168.2.1 255.255.255.0 
R2(config-if)#no shutdown 
R2(config-if)#exit 
 
R2(config)#interface serial 2/0 
R2(config-if)#no shutdown 
R2(config-if)#ip address 192.168.4.2 255.255.255.0 
R2(config-if)#exit


R2(config)#router rip 
R2(config-router)#network 192.168.2.0 
R2(config-router)#network 192.168.4.0 
R2(config-router)#version 2 
R2(config-router)#end 
 
查看R2 
R2#show ip route

 

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*