网络工程师Cisco路由器配置OSPF路由配置

Cisco路由器OSPF配置命令

OSPF开放式最短路径优先协议,是目前网路中应用最广泛的路由协议之一。属于
内部网管路由协议,能够适应各种规模的网络环境,是典型的链路状态协议。OSPF
路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个
具有全网链路状态的数据库,然后路由器采用 SPF 算法,以自己为根,计算到达
其他网络的最短路径,最终形成全网路由信息。

拓扑及实验要求
实验目的
 掌握OSPF协议的配置方法;
 掌握查看通过劢态路由协议OSPF学习产生的路由;
 熟悉广域网线缆的链接方式;

实验步骤
1) 新建packet tracer拓扑图。
2) 在本实验中的三层交换机上划分VLAN10和VLAN20,其中VLAN10用于连接校
园网主机,VLAN20用于连接R1。
3) 路由器之间通过 V35 电缆通过串口连接,DCE 端连接在 R1 上,配置其时钟频率
64000。
4) 主机和交换机通过直连线,主机不路由器通过交叉线连接。
5) 在S3560上配置 OSPF路由协议。
6) 在路由器R1、R2 上配置OSPF路由协议。
7) 将PC1、PC2主机默认网关设置为不直连网路设备接口IP地址。
8) 验证PC1、PC2主机之间可以互相同信;
实验设备
PC 2台;Switch_3560 1台;Router-PT 2台;直连线;交叉线;DCE串口线

S1配置 
Switch>en 
Switch#conf t 
Switch(config)#hostname S1 
 
S1(config)#vlan 10 
S1(config-vlan)#exit 
 
S1(config)#vlan 20 
S1(config-vlan)#exit 
 
S1(config)#interface fastEthernet 0/10 
S1(config-if)#switchport access vlan 10 
S1(config-if)#exit 
 
S1(config)#interface fastEthernet 0/20 
S1(config-if)#switchport access vlan 20 
S1(config-if)#exit 
 
S1(config)#interface vlan 10 
S1(config-if)#ip address 192.168.1.1 255.255.255.0 
S1(config-if)#no shutdown 
S1(config-if)#exit 
 
S1(config)#interface vlan 20 
S1(config-if)#ip address 192.168.3.1 255.255.255.0 
S1(config-if)#no shutdown 
S1(config-if)#exit 
 
S1(config)#ip routing 
S1(config)#router ospf 1 
S1(config-router)#network 192.168.1.0 0.0.0.255 area 0 
S1(config-router)#network 192.168.3.0 0.0.0.255 area 0 
S1(config-router)#end 
S1#show vlan 
S1#show ip route 
S1#show run 
 
查看S1 
S1#show vlan
R1配置 
Router>en 
Router#conf t 
Router(config)#hostname R1 
 
R1(config)#interface fa 0/0 
R1(config-if)#no shutdown 
R1(config-if)#ip address 192.168.3.2 255.255.255.0 
R1(config-if)#exit 
 
R1(config)#interface serial 2/0 
R1(config-if)#no shutdown 
R1(config-if)#ip address 192.168.4.1 255.255.255.0 
R1(config-if)#clock rate 64000 
R1(config-if)#end 
 
R1#show ip route 
R1#conf t 
R1(config)#router ospf 1 
R1(config-router)#network 192.168.3.0 0.0.0.255 area 0 
R1(config-router)#network 192.168.4.0 0.0.0.255 area 0 
R1(config-router)#end 
R1#show ip route 
R1#show run 
 
查看R1 
R1#show ip route
R2配置 
Router>en 
Router#conf t 
Router(config)#hostname R2 
 
R2(config)#interface fastEthernet 0/0 
R2(config-if)#no shutdown 
R2(config-if)#ip address 192.168.2.1 255.255.255.0 
R2(config-if)#exit 
 
R2(config)#interface serial 2/0 
R2(config-if)#no shutdown 
R2(config-if)#ip address 192.168.4.2 255.255.255.0 
R2(config-if)#exit 
 
R2(config)#router ospf 1 
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0 
R2(config-router)#network 192.168.4.0 0.0.0.255 area 0 
R2(config-router)#end 
 
R2#show ip route 
R2#show run 
查看R2 
R2#show ip route

OSPF路由配置ok

网络工程师配置OSPF路由配置

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*