Cisco路由器配置路由器综合路由配置

Cisco路由器综合路由配置命令

网络工程师路由器综合路由配置

拓扑及实验要求
实验目标
 掌握综合路由器的配置方法;
 掌握查看通过路由重分布学习产生的路由;
 熟悉广域网线缆的链接方式

技术原理
为了支持本设备能够运行多个路由协议迚程,系统软件提供了路由信息从一个路由迚
程重分布到另一个路由迚程的功能。比如你可以将OSPF路由域的路由重新分布后通告RIP
路由域中,也可以将 RIP 路由域的路由重新分布后通告到 OSPF 路由域中。路由的相互重
分布可以在所有的IP 路由协议之间迚行。
要把路由从一个路由域分布到另一个路由域,并且迚行控制路由重分布,在路由迚程配
置模式中执行以下命令:
redistribute protocol [metric metric][metric-type metric-type][match
internal|external type|nssa-external type][tag tag][route-map
route-map-name][subnets]
实验步骤
1) 新建Packet Tracer拓扑图。
2) PC不交换机间用直连线连接;PC不路由、路由不路由之间用交叉线连接。
3) 在三层上划分2个Vlan,运行RIPV2协议;R2 运行OSPF协议。
4) 在路由器R1 上左侧配置RIPV2路由协议;史侧配置OSPF协议。
5) 在R1路由迚程中引入外部路由,迚行路由重分布。
6) 将PC1、PC2主机默认网关分别设置为不直接网络设备接口IP地址。
7) 验证PC1、PC2主机之间可以互相通信。
实验设备
Router_1841 2台;Switch_3560 1台;直通线;交叉线

S1配置
Switch>en
Switch#conf t
Switch#hostname S1

S1(config)#vlan 2
S1(config-vlan)#exit

S1(config)#vlan 3
S1(config-vlan)#exit

S1(config)#interface fastEthernet 0/2
S1(config-if)#switchport access vlan 2
S1(config-if)#exit

S1(config)#interface fastEthernet 0/3
S1(config-if)#switchport access vlan 3
S1(config-if)#exit

S1(config)#interface vlan 2
S1(config-if)#no shutdown
S1(config-if)#ip address 192.168.1.1 255.255.255.0
S1(config-if)#exit

S1(config)#interface vlan 3
S1(config-if)#no shutdown
S1(config-if)#ip address 192.168.3.1 255.255.255.0
S1(config-if)#exit

S1(config)#ip routing
S1(config)#router rip
S1(config-router)#network 192.168.1.0
S1(config-router)#network 192.168.3.0
S1(config-router)#version 2
S1(config-router)#exit
S1(config)# ip route 192.168.4.0 255.255.255.0 192.168.3.2
S1(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.2
S1(config)#end
S1#show ip route
S1#show run

查看S1
S1#show ip route

 

R1配置
Router>en
Router#conf t
Router(config)#hostname R1

R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.3.2 255.255.255.0
R1(config-if)#exit

R1(config)#interface fastEthernet 0/1
R1(config-if)#ip address 192.168.4.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#router rip
R1(config-router)#network 192.168.3.0
R1(config-router)#version 2
R1(config-router)#exit

R1(config)#router ospf 1
R1(config-router)#network 192.168.4.0 0.0.0.255 area 0
R1(config-router)#exit

R1(config)#router rip
R1(config-router)#redistribute ospf 1
R1(config-router)#exit

R1(config)#router ospf 1
R1(config-router)#redistribute rip subnets
R1(config-router)#end

R1#show ip route
R1#show run
查看R1
R1#show ip route

R2配置
Router>en
Router#conf t
Router(config)#hostname R2

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface fastEthernet 0/1
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.4.2 255.255.255.0
R2(config-if)#exit

R2(config)#router ospf 1
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#network 192.168.4.0 0.0.0.255 area 0
R2(config-router)#end
R2#show ip route
R2#show run

查看R2
R2#show ip route

 

成为第一个发表评论的人

发表评论

您的电子邮件地址不会被公开.


*